README

Need more useless stuff to read on teh internetz?

Posts Tagged ‘firefox’

Firefox scrolling: One more time…

Posted by anjilslaire on December 16, 2008

OK, beating a dead horse, I know.

Out of the blue, my mouse starting acting up again, thinking the “back” button was clicked in Firefox 3 when I scroll up. Did I say “again”?

I was about to pull my hair out, as I live by my trusty scroll wheel. The new xorg.conf in Intrepid doesn’t accept configuration changes. That is to say, you can edit /etc/X11/xorg.conf all you want, and it doesn’t care. Xserver will use its own settings as it sees fit, thank you. This of course makes my previously posted mouse config settings obsolete.

So, after more searching I’ve finally found a bug on Launchpad that describes the situation perfectly, and also includes a working fix. While I certainly don’t take credit for the fix, it has a simple solution:

sudo rmmod psmouse && sudo modprobe psmouse rate=100 proto=imps

And a permanent fix, add the following to /etc/modprobe.d/options:

#Fix mouse for KVM
options psmouse proto=imps

Hopefully this is finally put to rest. Now, the inability to edit xorg.conf is a whole ‘nother pet peeve…

Advertisements

Posted in internetz, kubuntu, linux, rants, ubuntu, xubuntu | Tagged: , , , , , , , | Leave a Comment »

Firefox+mouse, Part III – done

Posted by anjilslaire on June 17, 2008

OK, I’m weak. After seeing that Firefox 3.0 RTMed today, and that it was finally in the repositories, I installed it again. Not surprisingly, the mouse behaved normally, and I can scroll up & down with impunity. All is good…

But I’m keeping Firefox 2 as a backup ūüėČ

Posted in kubuntu, linux, ubuntu | Tagged: , , , | Leave a Comment »

Firefox+mouse, part II

Posted by anjilslaire on June 16, 2008

Ok, so after fussing with Firefox 3 for a while, I decided fighting to get basic mouse functioning in a single browser wasn’t worth the fuss. I went back to Firefox 2.0.0.14, and all is well. We’ll see how 3.0 is after another update or 2.

Posted in kubuntu, linux, ubuntu | Tagged: , , | Leave a Comment »

Firefox 3 latest + mouse wheel scroll = ouch

Posted by anjilslaire on June 13, 2008

Ok,

I’ve discovered today that Firefox 3.0, aka 3.0~rc1+nobinonly-0ubuntu0.8.04.1 is causing issues with my mouse.
It’s just a standard, cheap 2button+wheel optical mouse (making 5 buttons technically) from logitech. It’s always treated me well.

The problem is, in Firefox if I use the wheel to scroll up, it acts lke I hit the Back button, and the previous page loads. Highly annoying, to say the least.

No, there is no problem with my xorg.It’s been set as both of the following, with no change:
Section “InputDevice”
Identifier¬†¬†¬† “Configured Mouse”
Driver¬†¬†¬† ¬†¬†¬† “mouse”
Option¬†¬†¬† ¬†¬†¬† “CorePointer”
Option¬†¬†¬† ¬†¬†¬† “Device”¬†¬†¬† “/dev/input/mice”
Option¬†¬†¬† ¬†¬†¬† “Protocol”¬†¬†¬† “ExplorerPS/2”
Option¬†¬†¬† ¬†¬†¬† “ZAxisMapping”¬†¬†¬† “4 5”
Option¬†¬†¬† ¬†¬†¬† “Emulate3Buttons”¬†¬†¬† “false”
EndSection

and simply as

Section “InputDevice”
Identifier¬†¬†¬† “Configured Mouse”
Driver¬†¬†¬†¬†¬†¬†¬† “mouse”
Option¬†¬†¬†¬†¬†¬†¬† “CorePointer”
EndSection

And yes, I’ve loaded about:config and check the appropriate settings:
mousewheel.horizscroll.withnokey.action = 0
mousewheel.withnokey.action = 0

No change. And, If I load Firefox 2.0.0.14, it behaves fine. So does Konqueror, and any other window browser app. Something is broken in Firefox, and it had better be fixed shortly. I’m not one to complain about FOSS (I haven’t payed for any of it), but this is highly annoying, right on th verge of 3.0 Final. I’ve hunted around, and haven’t found any solution that works. Maybe somebody can provide some insight.

Posted in kubuntu, linux, ubuntu | Tagged: , , , , | 3 Comments »